March 11, 2023 | Category : Other

Hi Artisan,
Are you looking for an example of laravel/framework[v10.0.0. you will learn .... you can understand a concept of v10.0.3] require composer-runtime-api ^2.2. This example will help you laravel 10 laravel/framework[v10.0.0.


Problem 1

- laravel/framework [v10.0.0, ..., v10.0.3] require composer-runtime-api ^2.2 -> found composer-runtime-api[2.1.0] but it does not match the constraint.

- Root composer.json requires laravel/framework ^10.0 -> satisfiable by laravel/framework [v10.0.0, v10.0.1, v10.0.2, v10.0.3].


Then i research and found that i had old composer version and i need to update it using the below command:

If you have same problem then you need to run following two commands and fix the problem:


composer clearcache

composer selfupdate

I hope it can help you...